vBulletin

软件 vBulletin 5.6.1

登录后下载
资源类型
转载
版权链接
www.vbulletin.com
适用平台
Web
依赖
PHP 7.2+,Mysql 5.6.10+,MariaDB 10.0.10+
语言
多语言
vBulletin 5.6.1 更改和更新
vBulletin Connect 5.6.1 现在可供下载

前端变化

博客

网格视图已被添加到博客列表中,这与群组上的网格视图的工作原理类似
除此以外,还在博客列表中添加了分类功能
vBulletin_5.6.1_1.png

用户推荐

vBulletin Connect中增加了一个用户推荐系统
通过这个系统,用户将能够检索到一个自定义的URL,他们可以提供给他们的朋友和家人在您的网站上注册
默认情况下,他们可以在他们的用户资料页面上检索到这个链接
使用时,推荐链接将创建一个cookie
在注册时,他们会给推荐人一个推荐信用
在AdminCP中,您将能够在新的推荐人页面(Admin CP -> 用户 -> 推荐人)上查看推荐人的情况

管理员有几个控件来管理
首先是一个设置,允许您指定推荐链接的有效时间,默认是30天,你可以在AdminCP中的 "设置->选项->用户注册选项 "下更改
此外,每个用户组都有一个 "可以推荐用户 "权限。 如果这个权限设置为否,用户将无法生成推荐链接

如果你想提供额外的链接来生成推荐用户,你可以在任何标准的HTML链接上添加js-refer-user CSS类到链接中
例如:
HTML:
<a href="#" class="js-refer-user">转介链接</a>
通知

改进了页面标题中通知的显示方式,通知链接现在是一个下拉菜单,列出了每种类型的通知数量
这个列表还将包括报告/标记的帖子和未批准的帖子,以便于修改
当用户激活了vBulletin Messenger时,这个列表将在页面加载之间自动更新
vBulletin_5.6.1_2.png


JavaScript更新

为了提供更新和更简洁的代码,对一些JavaScript文件进行了广泛的重构
在重构过程中,可能会删除了一些被废弃的代码
如果您在安装此版本后遇到问题,您应该刷新浏览器缓存,以确保所有文件都正常更新
如果问题仍然存在,请通过提交错误报告来通知我们


其他已解决的问题


修复了社交群组成员列表的分页功能

用户现在可以在编辑器中选择多个表情符号,而不必为每个表情符号重新打开面板

在线/离线状态图标已恢复到发布位。

解决了可能导致编辑后的文章发布日期提前一个月的问题。

解决了无法合并图片库帖子的问题。

改进了非英语语言的日期处理。

如果用户没有下载附件的权限,系统现在会显示一个正确的错误页面。

私有频道和隐形频道将不再显示在搜索结果中,私人频道是指用户没有权限查看的频道,隐形频道是指那些显示顺序为0的频道。

在搜索模块中增加了一个选项,以便从搜索结果中过滤未批准的帖子

更新了所有留言中心页面的布局,使其在响应式模式下能更好地工作

解决了一个问题,因此 vBulletin Cloud 管理员在访问网站生成器中的页面管理器时,不会再收到 "Invalid Node ID"

改进了本地存储中短语的缓存。


后端 / 管理程序的更改

隐私和同意

隐私和同意工具已经扩展到允许管理员决定接受哪些国家和州的同意
要选择你想接受隐私同意的地区,请访问 "设置"->"位置"
一个新的安装将有两个位置的定义,如:加州和欧盟
vBulletin_5.6.1_3.png

点击 "添加位置",您可以从国家和/或美国所有50个国家的列表中选择
除了预定义的区域外,您还可以在位置屏幕上添加您自己的自定义区域
自定义区域的值取决于所使用的GEOIP API的输出
vBulletin_5.6.1_4.png

一旦你选择了你的区域,然后在 "设置->选项->隐私选项 "下设置你的隐私选项。


节点工具

解决了各种阻碍移动/调整节点正常工作的问题。


语言定位

法语、德语和西班牙语语言包将正确地在指定的Locale中包含.utf8后缀。 这将为UTF-8字符提供更好的支持。
从传统版本升级

从旧版本的vBulletin 3.X升级时使用的升级步骤已经更新,以解决因支持旧版本的PHP而导致的潜在错误。

早期的vBulletin 5.X升级步骤已经更新,以改善ID不连续时导入内容的问题。 除此之外,对早期5.X系列中的各种升级步骤的反馈也进行了更新,在提供进度更新的同时,更加简洁。


其他已解决的问题

解决了发送出去的邮件会有不正确的语言分配的问题。

解决了各种问题,提高了对 PHP 7.4 的支持。

删除了过期的公共用户组权限。

解决了一个可能导致搜索日志过早删除缓存的问题

其他信息

安装/升级

文件清理

在升级vBulletin系统后,您应该删除任何可能过时的文件。 您可以在 vBulletin 5 安装和升级论坛中的这个主题中获得更多关于为什么需要这样做的信息和说明。


系统要求

最低系统要求
  • PHP Version: 7.2.0
  • MySQL Version: 5.6.10
  • MariaDB Version: 10.1.0
推荐系统参数
  • PHP Version: 7.3 或者更高
  • MySQL Version: 8.0 或者更高
  • MariaDB Version: 10.3+
有关更多信息,请参阅 vBulletin Connect 系统要求

当前版本支持时间表

活动版本 - 5.6.1
安全补丁 - 5.6.1
安全补丁 - 5.5.6
无补丁发布版 - 5.5.5.5或更早版本
作者
CJJ是鸟战猪不是鸟袋猪
价格
金粒1粒
下载
1
阅读
461
首次发布
最后更新
评分
0.00 星 0 次评分

CJJ是鸟战猪不是鸟袋猪的更多资源